Coding Practice
Showing posts with label Uppercase Lowercase. Show all posts
Showing posts with label Uppercase Lowercase. Show all posts

Java Output Formatting | HackerRank

Java Output Formatting

Java's System.out.printf function can be used to print formatted output. The purpose of this exercise is to test your understanding of formatting output using printf.

To get you started, a portion of the solution is provided for you in the editor; you must format and print the input to complete the solution.

Input Format

Every line of input will contain a String followed by an integer.

Each String will have a maximum of 10 alphabetic characters, and each integer will be in the inclusive range from 0 to 999.

Output Format

In each line of output there should be two columns:
The first column contains the String and is left justified using exactly 15 characters.
The second column contains the integer, expressed in exactly 3 digits; if the original input has less than three digits, you must pad your output's leading digits with zeroes.

Sample Input

java 100
cpp 65
python 50

Sample Output

================================
java           100
cpp            065
python         050
================================

Explanation

Each String is left-justified with trailing whitespace through the first 15 characters. The leading digit of the integer is the 16th character, and each integer that was less than 3 digits now has leading zeroes.

Sample Output
java 100
cpp 65
python 50
================================
java           100 
cpp            065 
python         050 
================================
Java-Source Code
import java.util.Scanner;

public class Solution {
    
    public static void main(String[] args) {
        Scanner sc=new Scanner(System.in);
        System.out.println("================================");
        for(int i=0;i<3;i++){
            String s1=sc.next();
            int x=sc.nextInt();
            System.out.printf("%-13s  %03d\n", s1, x);
        }
        System.out.println("================================");
    }
}
Sample Output
java 100
cpp 65
python 50
================================
java           100 
cpp            065 
python         050 
================================


Welcome to Java! | HackerRank

Welcome to Java!

Welcome to the world of Java! In this challenge, we practice printing to stdout.

The code stubs in your editor declare a Solution class and a main method. Complete the main method by copying the two lines of code below and pasting them inside the body of your main method.

System.out.println("Hello, World.");

System.out.println("Hello, Java.");

Input Format

There is no input for this challenge.

Output Format

You must print two lines of output:

  1. Print Hello, World. on the first line.
  2. Print Hello, Java. on the second line.

Sample Output

Hello, World.

Hello, Java.

Sample Output
Hello, World.
Hello, Java.


...Program finished with exit code 0
Press ENTER to exit console.
Java-Source Code
public class Solution {

    public static void main(String[] args) {
        System.out.println("Hello, World.");
        System.out.println("Hello, Java.");
    }
}
Sample Output
Hello, World.
Hello, Java.


...Program finished with exit code 0
Press ENTER to exit console.


Write a C program to check whether a character is uppercase or lowercase alphabet

Check a character is uppercase or lowercase alphabet
Sample Output
Enter a character: p

p is lowercase alphabet.

Process returned 0 (0x0)   execution time : 1.219 s
Press any key to continue.
Source Code
#include<stdio.h>

int main()
{
    char ch;

    printf("Enter a character: ");
    scanf("%c", &ch);

    if(ch >= 'a' && ch <= 'z')
    {
        printf("\n%c is lowercase alphabet.\n", ch);
    }
    else if(ch >= 'A' && ch <= 'Z')
    {
        printf("\n%c is uppercase alphabet.\n", ch);
    }
    else
    {
        printf("\nInvalid Alphabet!\n");
    }
    return 0;
}
Sample Output
Enter a character: M

M is uppercase alphabet.

Process returned 0 (0x0)   execution time : 2.789 s
Press any key to continue.
Change Theme
X